Note: due to massive spam issues, the forum registration is now closed. If needed, you may still contact me at the following address:

Hi thanks for the launcher, it's wonderful...

But I have an error:When I press the right click on a shortcut, the program crash and shows me this:

With the previous version didn't happen it... Look:

My system:

  • WinXP Sp3.
  • 1 GB de Ram.

Any suggestions?

PD: I'm Latino so if I have spelling errors, sorry.

Well, at first place, I try to upgrade my old version 1.3 with 1.4, and all my links were deleted.

Is there any way to recover them? There was a bunch of folders and links stored in the old appetizer 1.3 :'-(

Second, the same failure of the user of above. When I do right click on appetizer, it crash without any message.

With version 1.3 I have no problems to add folders and links.

OS: WinXP SP3 / 1GB RAM.

Yup, I'm latino too, but I'm from Mexico and my MS Windows is US version, not the spanish version.

Mexico, most likely your links are not deleted. I think Appetizer is just looking for your setting files in the wrong folder and as a result it looks like everything has been reset. In order to find out what the problem is, could you let me know which Appetizer package you are using? Is it the .zip, the .paf.exe (PortableApps format) or the .exe (standard installer)?

I don't know what's causing the XP issue. I will do some tests and will let you know.

I tested with the two options and both crashed. (.exe and .zip). The .paf.exe package I haven't tried, where is?
Plz fix this problem, it's my favorite launcher...
(I am the post's creator)

Estuart, I just gave a try to the Spanish version on Windows XP SP2 but didn't get any crash.

I may try SP3 later but first it would useful to know exactly which settings you are using. So do you think you could send me a copy of your Settings.xml file? It's in the Data/Settings folder of Appetizer. You can also open the setting file with any text editor and copy and paste the result here if you want. Once I know what combination of settings are causing the crash, I should be able to fix it.

Sure, here you are the 4 xml files.

Off-topic :-P: You can put in future versions the option to enlarge the icons for more than 48 pixels?
Or I can do in this version? If so, how?

I was using appetizer, then I download the last version 1.4 and replace the old version 1.3 executable with the new one.

When I launch the new Appetizer.exe, the links disappeared.

About the right click I think maybe appetizer is calling a dll windows library that maybe my Win lacks, because I went to other machine with Windows spanish version and works the right click very fine (I also have some time to re-create the major part of the missing links).

But is something weird that in the other computer that I have with WinXP english won't work the right click.

Mexico, the folder structure of Appetizer should be as follow:


The file that contains your shortcuts is FolderItems.xml and the file containing the config is Settings.xml. Make sure that the folders on your drive match this structure and that you have these two XML files.

Now, if you have a backup of Settings.xml and FolderItems.xml, copy them over the existing files. Also if you used to have a PortableApps version of Appetizer, the files may still be on your drive in this folder: PortableApps\Appetizer\App\Appetizer\Data\Settings . Simply copy them from this folder to the new one.

Thanks, Laurent, I haven't a backup, but at this very moment will make one so I don't loose again the settings. =)

Update about the right click and appetizer.

When I use in WinXPSP3 spanish it works OK.

When I use in WinXPSP3 english it crashes.


Got the same bug

If you are talking about the crash, please see this post. If you are talking about the missing icons, the last version available on the Download page should fix the issue.